Telefunken PALcolor P 150M - kein OSD mehr

  • Hallo zusammen,

    ich habe hier einen Telefunken PALcolor P 150 M im Gästezimmer, der ging eigentlich immer mit einem super tollen Bild.

    Jedoch seit gestern kommt kein OSD Anzeige mehr, die Bedientasten an der Front und die Fernbedienung funktioniert nicht mehr.
    Bild kommt, typisches Rauschbild mit ohne Sender.

    Ich vermute eine fehlende Spannung (oder ein anderer Fehle) für die Steuerung von OSD und Bedienungslogik.

    Leider habe ich keinen Schaltplan und keine Serviceunterlagen wo man nachsehen könnte, kann jemand helfen? Weiß jemand was?

    Danke ...

  • Hallo Hari,

    Das könnte ein Fehler im I2C Bus sein. Das ist ein Bus mit einer Takt und einer Datenleitung. Damit werden befehle und auch OSD Infos innerhalb des Geräte übertragen. Wenn nur eine Komponente den Bus blockiert z.B. indem sie eine Leitung auf Masse oder + dauerhaft zieht, dann hast Du diese Symptome.

    Ich habe das oft bei Sony Geräten einer bestimmten Serie gehabt. Das Gerät ließ sich nicht mehr bedienen oder einschalten. Der Fehler war im Tuner(!). Eine Masseverbindung hatte sich darin gelöst und den I2C Bus der auch die PLL im Tuner gesteuert hat auf ein hohes Potential gezogen. Damit gingen keine Befehle mehr über den Bus und das Gerät hat nicht mehr reagiert.

    Was ich hier schreibe sind nur Vermutungen in welcher Richtung der Fehler liegen könnte.

    Viele Grüße
    Semir
    ---------------------------------
    "Alle sagten: Das geht nicht. Dann kam einer der wusste das nicht, und hat es gemacht."
    (Prof. Hilbert Meyer, Uni Oldenburg)

  • Servus Hari,

    Quote from "Semir" pid="277027" dateline="1717086248"


    Das könnte ein Fehler im I2C Bus sein.

    Defekte, die durch "festgenagelte" Pegel am I²C-Bus herrühren, habe ich hier und da auch schon gesehen. Dadurch, daß der I²C-Bus aber nur zwei (bidirektionale) Leitungen hat (SDA und SCL), an der in der Regel ein Haufen ICs in solchen Kisten angeschlossen sind, sollte sich auch ohne Schaltbild anhand des Datenblatts eines "digital gesteuert aussehenden" ICs rausfinden lassen, wo diese zwei Signalpins und die Masse für den I²C-Bus an diesem IC liegen. Der I²C-Bus ist langsam: Der Takt "SCL" ist entweder 100[kHz] oder - in seltenen Fällen - 400[kHz]. Das sollte man also oszilloskopisch auch mit langsamen Scopes gut messen können. Ein Dauer-Low oder Dauer-High am SDA bei vorhandenem Takt am SCL ist kein gutes Zeichen.....und wenn am SCL kein Takt, sondern nur ein Dauer-Low oder Dauer-High anliegt, ist das auch nicht gut.....

    Grüße

    Günter

    100[MHz]? Für Mikrowellenleute leicht welliger Gleichstrom.... :D

    Edited once, last by Klangschatulle (May 30, 2024 at 10:45 PM).

  • Moin!
    Nun mal langsam.
    Bevor wir den Fredersteller verwirren:
    Ohne Schaltbild wird das nix.
    Leider ist zu P150M nichts zu finden, also:
    Steht auf dem Aufkleber auf der Rückseite eine Chassisnummer(ICC..., 418A etc)?
    Wenn nicht, ist auf dem Chassis selbst meist eine Angabe auf einem Aufkleber, und zur Not helfen Fotos.
    Gruß Gerrit

Participate now!

Don’t have an account yet? Register yourself now and be a part of our community!